CVE-2025-47940 TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
Administrators can escalate privileges to system maintainer in TYPO3 CMS, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47940?
CVE-2025-47940 is a high-severity vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Weakness: CWE-283
Which versions are affected by CVE-2025-47940?
8 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.4.0 | 10.4.50 |
typo3/cms-core Packagist | From 10.4.0 | 10.4.50 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.44 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.44 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.31 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.31 |
2 more packages
typo3/cms-core Packagist | From 13.0.0 | 13.4.12 |
typo3/cms-core Packagist | From 13.0.0 | 13.4.12 |
Products include Typo3 Typo3.
How do I fix CVE-2025-47940?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.50, 11.5.44, 12.4.31 or 13.4.12.
Is CVE-2025-47940 being exploited?
There is no known exploitation of CVE-2025-47940 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-6frx-j292-c844.