# CVE-2025-47941: TYPO3 Has Broken Authentication in Backend MFA

> Attackers with valid credentials can bypass backend MFA due to insufficient access restrictions on backend routes.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-744g-7qm9-hjh9

## What is CVE-2025-47941?

CVE-2025-47941 is a high-severity authentication bypass vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, the multifactor authentication (MFA) dialog presented during backend login can be bypassed due to insufficient enforcement of access restrictions on all backend routes. Successful exploitation requires valid backend user credentials, as MFA can only be bypassed after successful authentication. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to fix the problem.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-47941?

4 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-backend` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-backend` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-backend` | Packagist | From 13.0.0 | 13.4.12 |
| `typo3/cms-backend` | Packagist | From 13.0.0 | 13.4.12 |

Products: Typo3 Typo3.

## How do I fix CVE-2025-47941?

Upgrade typo3/cms-backend to a fixed version for your release line: 12.4.31 or 13.4.12.

## Is CVE-2025-47941 being exploited?

There is no known exploitation of CVE-2025-47941 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47941 and fix it if it is affected.

What it is: CVE-2025-47941 is a high-severity authentication bypass vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47941 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-backend (Packagist): affected from 12.0.0; fixed in 12.4.31
- typo3/cms-backend (Packagist): affected from 12.0.0; fixed in 12.4.31
- typo3/cms-backend (Packagist): affected from 13.0.0; fixed in 13.4.12
- typo3/cms-backend (Packagist): affected from 13.0.0; fixed in 13.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47941/ (Markdown: https://insights.sbomify.com/CVE-2025-47941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47941
- OSV: https://osv.dev/vulnerability/CVE-2025-47941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47941/
Summaries are generated and may contain mistakes; the official description above is the record.
