# CVE-2025-47943: Gogs stored XSS in PDF renderer

> Stored XSS in Gogs allows client-side JavaScript execution via a vulnerable PDF renderer component, requiring an upgrade to fix.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-xh32-cx6c-cp4v, GO-2025-3778

## What is CVE-2025-47943?

CVE-2025-47943 is a medium-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-47943?

5 open source packages ship an affected version, including gogs.io/gogs and github.com/gogs/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.13.3-0.20250608224432-110117b2e5e5 |
| `gogs.io/gogs` | Go | All versions | 0.13.3-0.20250608224432-110117b2e5e5 |
| `gogs.io/gogs` | Go | All versions | 0.13.3-0.20250608224432-110117b2e5e5 |
| `github.com/gogs/gogs` | Go | All versions | 0.13.3-0.20250608224432-110117b2e5e5 |
| `github.com/gogs/gogs` | Go | All versions | 0.13.3-0.20250608224432-110117b2e5e5 |

## How do I fix CVE-2025-47943?

Upgrade gogs.io/gogs to 0.13.3-0.20250608224432-110117b2e5e5 or later.

## Is CVE-2025-47943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47943 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47943 and fix it if it is affected.

What it is: CVE-2025-47943 is a medium-severity cross-site scripting vulnerability in gogs, published on 24 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47943 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3-0.20250608224432-110117b2e5e5
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3-0.20250608224432-110117b2e5e5
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3-0.20250608224432-110117b2e5e5
- github.com/gogs/gogs (Go): affected all versions; fixed in 0.13.3-0.20250608224432-110117b2e5e5
- github.com/gogs/gogs (Go): affected all versions; fixed in 0.13.3-0.20250608224432-110117b2e5e5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47943/ (Markdown: https://insights.sbomify.com/CVE-2025-47943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47943
- OSV: https://osv.dev/vulnerability/CVE-2025-47943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47943/
Summaries are generated and may contain mistakes; the official description above is the record.
