CVE-2025-47944 Multer vulnerable to Denial of Service from maliciously crafted requests

High 7.5 Published Updated

An attacker can crash the application process by sending a malformed multipart upload request to the Multer library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-47944?

CVE-2025-47944 is a high-severity denial of service vulnerability in expressjs multer, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.

Weakness: CWE-248

Which versions are affected by CVE-2025-47944?

2 open source packages ship an affected version, including multer.

PackageAffectedFixed in
multer npmFrom 1.4.4-lts.12.0.0
multer npmFrom 1.4.4-lts.12.0.0

How do I fix CVE-2025-47944?

Upgrade multer to 2.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-47944 being exploited?

There is no known exploitation of CVE-2025-47944 in the wild and no public exploit code.

Sources

Also known as GHSA-4pg4-qvpc-4q3h, ROOT-APP-NPM-CVE-2025-47944.

Is CVE-2025-47944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free