{"answers":{"affected":"2 open source packages ship an affected version, including cocotais-bot.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47948 exists.","fix":"Upgrade cocotais-bot to 1.6.2 or later.","what":"CVE-2025-47948 is a high-severity command injection vulnerability in cocotais-bot, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47948 and fix it if it is affected.\n\nWhat it is: CVE-2025-47948 is a high-severity command injection vulnerability in cocotais-bot, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47948 exists.\n\nAffected packages and fixed versions:\n- cocotais-bot (npm): affected from 1.5.0-test2-hotfix; fixed in 1.6.2\n- cocotais-bot (npm): affected from 1.5.0-test2-hotfix; fixed in 1.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47948/ (Markdown: https://insights.sbomify.com/CVE-2025-47948/index.md)","id":"CVE-2025-47948","markdown":"https://insights.sbomify.com/CVE-2025-47948/index.md","name":"CVE-2025-47948","record":{"aliases":["GHSA-mj2c-8hxf-ffvq"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"QQ bot framework","requires_auth":"none","summary":"An attacker can inject platform tags into the echo command to bypass permissions and spam mentions, affecting users of the Cocotais Bot framework.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Cocotais Bot is a QQ official robot framework based on qq-bot-sdk. Starting in version 1.5.0-test2-hotfix and prior to version 1.6.2, command echoing feature in the framework allows users to indirectly trigger privileged behavior by injecting special platform tags. Specifically, an unauthorized user can use the `/echo \u003cqqbot-at-everyone /\u003e` command to cause the bot to send a message that mentions all members in the chat, bypassing any permission controls. This can lead to spam, disruption, or abuse of notification systems. Version 1.6.2 contains a patch for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cocotais Bot has builtin .echo command injection","id":"CVE-2025-47948","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"samlify SAML Signature Wrapping attack","id":"CVE-2025-47949"},"packages":[{"ecosystem":"npm","fixed":["1.6.2"],"introduced":["1.5.0-test2-hotfix"],"last_affected":[],"package":"cocotais-bot","purl":null,"source":"GHSA-mj2c-8hxf-ffvq"},{"ecosystem":"npm","fixed":["1.6.2"],"introduced":["1.5.0-test2-hotfix"],"last_affected":[],"package":"cocotais-bot","purl":"pkg:npm/cocotais-bot","source":"GHSA-mj2c-8hxf-ffvq"}],"prev":{"headline":"ModSecurity Has Possible DoS Vulnerability","id":"CVE-2025-47947"},"products":["cocotais-bot"],"published":"2025-05-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-19","vendors":["cocotais"]},"summary":"An attacker can inject platform tags into the echo command to bypass permissions and spam mentions, affecting users of the Cocotais Bot framework.","url":"https://insights.sbomify.com/CVE-2025-47948/"}