# CVE-2025-47948: Cocotais Bot has builtin .echo command injection

> An attacker can inject platform tags into the echo command to bypass permissions and spam mentions, affecting users of the Cocotais Bot framework.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2025
- **Updated:** 19 May 2025
- **Also known as:** GHSA-mj2c-8hxf-ffvq

## What is CVE-2025-47948?

CVE-2025-47948 is a high-severity command injection vulnerability in cocotais-bot, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cocotais Bot is a QQ official robot framework based on qq-bot-sdk. Starting in version 1.5.0-test2-hotfix and prior to version 1.6.2, command echoing feature in the framework allows users to indirectly trigger privileged behavior by injecting special platform tags. Specifically, an unauthorized user can use the `/echo <qqbot-at-everyone />` command to cause the bot to send a message that mentions all members in the chat, bypassing any permission controls. This can lead to spam, disruption, or abuse of notification systems. Version 1.6.2 contains a patch for the issue.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-47948?

2 open source packages ship an affected version, including cocotais-bot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cocotais-bot` | npm | From 1.5.0-test2-hotfix | 1.6.2 |
| `cocotais-bot` | npm | From 1.5.0-test2-hotfix | 1.6.2 |

## How do I fix CVE-2025-47948?

Upgrade cocotais-bot to 1.6.2 or later.

## Is CVE-2025-47948 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47948 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47948 and fix it if it is affected.

What it is: CVE-2025-47948 is a high-severity command injection vulnerability in cocotais-bot, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47948 exists.

Affected packages and fixed versions:
- cocotais-bot (npm): affected from 1.5.0-test2-hotfix; fixed in 1.6.2
- cocotais-bot (npm): affected from 1.5.0-test2-hotfix; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47948/ (Markdown: https://insights.sbomify.com/CVE-2025-47948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47948
- OSV: https://osv.dev/vulnerability/CVE-2025-47948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47948/
Summaries are generated and may contain mistakes; the official description above is the record.
