# CVE-2025-47949: samlify SAML Signature Wrapping attack

> Attackers can forge SAML responses to authenticate as any user in samlify, requiring a signed XML document from the identity provider.

- **Severity:** Critical 9.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-r683-v43c-6xqv, ROOT-APP-NPM-CVE-2025-47949

## What is CVE-2025-47949?

CVE-2025-47949 is a critical authentication bypass vulnerability in tngan samlify, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

samlify is a Node.js library for SAML single sign-on. A Signature Wrapping attack has been found in samlify prior to version 2.10.0, allowing an attacker to forge a SAML Response to authenticate as any user. An attacker would need a signed XML document by the identity provider. Version 2.10.0 fixes the issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-47949?

2 open source packages ship an affected version, including samlify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `samlify` | npm | All versions | 2.10.0 |
| `samlify` | npm | All versions | 2.10.0 |

Products: Samlify Project Samlify.

## How do I fix CVE-2025-47949?

Upgrade samlify to 2.10.0 or later.

## Is CVE-2025-47949 being exploited?

There is no known exploitation of CVE-2025-47949 in the wild and no public exploit code.

## Other vulnerabilities in tngan samlify

- [CVE-2026-46490](https://insights.sbomify.com/CVE-2026-46490/): samlify: XML Injection in AttributeValue Allows Privilege Escalation in Signed SAML Assertions (high 8.7)
- [CVE-2017-1000452](https://insights.sbomify.com/CVE-2017-1000452/): Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47949 and fix it if it is affected.

What it is: CVE-2025-47949 is a critical authentication bypass vulnerability in tngan samlify, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47949 in the wild and no public exploit code.

Affected packages and fixed versions:
- samlify (npm): affected all versions; fixed in 2.10.0
- samlify (npm): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47949/ (Markdown: https://insights.sbomify.com/CVE-2025-47949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47949
- OSV: https://osv.dev/vulnerability/CVE-2025-47949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47949/
Summaries are generated and may contain mistakes; the official description above is the record.
