# CVE-2025-47950: CoreDNS Vulnerable to DoQ Memory Exhaustion via Stream Amplification


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jun 2025
- **Updated:** 6 Jun 2025
- **Also known as:** AZL-63678, AZL-63695, CLEANSTART-2026-QH90790, CLEANSTART-2026-WO45616, ECHO-fe0d-9184-e720, GHSA-cvx7-x8pj-x2gw, GO-2025-3743, MINI-69c3-3675-8c6q, MINI-7xxj-5w25-mq4x, MINI-8mpj-grww-mwxf, MINI-cj6h-whcx-mvgg, MINI-mh54-6rh3-c6vm, MINI-p2mf-rmc8-23r6

## What is CVE-2025-47950?

CVE-2025-47950 is a high-severity vulnerability in coredns, published on 6 Jun 2025. 

### Official description

CoreDNS is a DNS server that chains plugins. In versions prior to 1.12.2, a Denial of Service (DoS) vulnerability exists in the CoreDNS DNS-over-QUIC (DoQ) server implementation. The server previously created a new goroutine for every incoming QUIC stream without imposing any limits on the number of concurrent streams or goroutines. A remote, unauthenticated attacker could open a large number of streams, leading to uncontrolled memory consumption and eventually causing an Out Of Memory (OOM) crash — especially in containerized or memory-constrained environments. The patch in version 1.12.2 introduces two key mitigation mechanisms: `max_streams`, which caps the number of concurrent QUIC streams per connection with a default value of `256`; and `worker_pool_size`, which Introduces a server-wide, bounded worker pool to process incoming streams with a default value of `1024`. This eliminates the 1:1 stream-to-goroutine model and ensures that CoreDNS remains resilient under high concurrency.  Some workarounds are available for those who are unable to upgrade. Disable QUIC support by removing or commenting out the `quic://` block in the Corefile, use container runtime resource limits to detect and isolate excessive memory usage, and/or monitor QUIC connection patterns and alert on anomalies.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-47950?

3 open source packages ship an affected version, including github.com/coredns/coredns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | All versions | 1.12.2 |
| `github.com/coredns/coredns` | Go | All versions | 1.12.2 |
| `github.com/coredns/coredns` | Go | All versions | 1.12.2 |

Products: Coredns.io Coredns.

## How do I fix CVE-2025-47950?

Upgrade github.com/coredns/coredns to 1.12.2 or later.

## Is CVE-2025-47950 being exploited?

There is no known exploitation of CVE-2025-47950 in the wild and no public exploit code.

## Other vulnerabilities in coredns

- [CVE-2026-32934](https://insights.sbomify.com/CVE-2026-32934/): CoreDNS DNS-over-QUIC unbounded goroutine growth leads to denial of service (high 8.7)
- [CVE-2026-32936](https://insights.sbomify.com/CVE-2026-32936/): CoreDNS DoH GET path missing size validation causes CPU and memory amplification (high 8.7)
- [CVE-2026-33190](https://insights.sbomify.com/CVE-2026-33190/): CoreDNS TSIG authentication bypass on encrypted DNS transports (high 8.7)
- [CVE-2026-33489](https://insights.sbomify.com/CVE-2026-33489/): CoreDNS transfer plugin subzone ACL bypass via lexicographic zone comparison (high 8.2)
- [CVE-2026-35579](https://insights.sbomify.com/CVE-2026-35579/): CoreDNS TSIG authentication bypass on gRPC, QUIC, DoH, and DoH3 transports (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47950 and fix it if it is affected.

What it is: CVE-2025-47950 is a high-severity vulnerability in coredns, published on 6 Jun 2025. 
Exploitation: There is no known exploitation of CVE-2025-47950 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.12.2
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.12.2
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47950/ (Markdown: https://insights.sbomify.com/CVE-2025-47950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47950
- OSV: https://osv.dev/vulnerability/CVE-2025-47950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47950/
Summaries are generated and may contain mistakes; the official description above is the record.
