# CVE-2025-47951: Weblate lacks rate limiting when verifying second factor

> Attackers can bypass two-factor authentication by automating OTP guessing due to missing rate limits, potentially taking over accounts.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-57jg-m997-cx3q, PYSEC-2026-2039

## What is CVE-2025-47951?

CVE-2025-47951 is a medium-severity vulnerability in WeblateOrg weblate, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web based localization tool. Prior to version 5.12, the verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing. This issue has been patched in version 5.12.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-47951?

3 open source packages ship an affected version, including weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.12 |
| `weblate` | PyPI | All versions | 5.12 |
| `weblate` | PyPI | All versions | 5.12 |

Products: Weblate Weblate.

## How do I fix CVE-2025-47951?

Upgrade weblate to 5.12 or later.

## Is CVE-2025-47951 being exploited?

There is no known exploitation of CVE-2025-47951 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47951 and fix it if it is affected.

What it is: CVE-2025-47951 is a medium-severity vulnerability in WeblateOrg weblate, published on 16 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47951 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.12
- weblate (PyPI): affected all versions; fixed in 5.12
- weblate (PyPI): affected all versions; fixed in 5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47951/ (Markdown: https://insights.sbomify.com/CVE-2025-47951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47951
- OSV: https://osv.dev/vulnerability/CVE-2025-47951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47951/
Summaries are generated and may contain mistakes; the official description above is the record.
