# CVE-2025-48042: Before action hooks may execute in certain scenarios despite a request being forbidden

> Attackers can trigger before-action hooks in the Ash library even when requests are forbidden, bypassing intended access controls.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2025
- **Updated:** 22 Sep 2026
- **Also known as:** EEF-CVE-2025-48042, GHSA-jj4j-x5ww-cwh9

## What is CVE-2025-48042?

CVE-2025-48042 is a high-severity missing authorization vulnerability in ash-project ash, published on 7 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash allows Exploiting Incorrectly Configured Access Control Security Levels.

This issue affects ash: from 0.1.1 before 3.5.39.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-48042?

3 open source packages ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | All versions | 3.5.39 |
| `ash` | Hex | All versions | 3.5.39 |
| `ash` | Hex | From 0.1.1 | 3.5.39 |

## How do I fix CVE-2025-48042?

Upgrade ash to 3.5.39 or later.

## Is CVE-2025-48042 being exploited?

There is no known exploitation of CVE-2025-48042 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48042 and fix it if it is affected.

What it is: CVE-2025-48042 is a high-severity missing authorization vulnerability in ash-project ash, published on 7 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48042 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash (Hex): affected all versions; fixed in 3.5.39
- ash (Hex): affected all versions; fixed in 3.5.39
- ash (Hex): affected from 0.1.1; fixed in 3.5.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48042/ (Markdown: https://insights.sbomify.com/CVE-2025-48042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48042
- OSV: https://osv.dev/vulnerability/CVE-2025-48042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48042/
Summaries are generated and may contain mistakes; the official description above is the record.
