# CVE-2025-48044: Authorization bypass when bypass policy condition evaluates to true

> Attackers can bypass authorization checks when specific policy conditions are met, potentially gaining unauthorized access to protected resources.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2025
- **Updated:** 22 Sep 2026
- **Also known as:** EEF-CVE-2025-48044, GHSA-pcxq-fjp3-r752

## What is CVE-2025-48044?

CVE-2025-48044 is a high-severity authentication bypass vulnerability in ash-project ash, published on 17 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash allows Authentication Bypass.

This issue affects ash: from 3.6.3 before 3.7.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-48044?

3 open source packages ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 3.6.3 | 3.7.1 |
| `ash` | Hex | From 3.6.3 | 3.7.1 |
| `ash` | Hex | From 3.6.3 | 3.7.1 |

## How do I fix CVE-2025-48044?

Upgrade ash to 3.7.1 or later.

## Is CVE-2025-48044 being exploited?

There is no known exploitation of CVE-2025-48044 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48044 and fix it if it is affected.

What it is: CVE-2025-48044 is a high-severity authentication bypass vulnerability in ash-project ash, published on 17 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48044 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash (Hex): affected from 3.6.3; fixed in 3.7.1
- ash (Hex): affected from 3.6.3; fixed in 3.7.1
- ash (Hex): affected from 3.6.3; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48044/ (Markdown: https://insights.sbomify.com/CVE-2025-48044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48044
- OSV: https://osv.dev/vulnerability/CVE-2025-48044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48044/
Summaries are generated and may contain mistakes; the official description above is the record.
