CVE-2025-48053 Discourse vulnerable to DoS via large URL payload in PM to a bot

High 8.7 Published Updated

Attackers can cause denial of service by sending malicious URLs in private messages to bot users, affecting Discourse forum availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48053?

CVE-2025-48053 is a high-severity denial of service vulnerability in Discourse Discourse, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, sending a malicious URL in a PM to a bot user can cause a reduced the availability of a Discourse instance. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. No known workarounds are available.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2025-48053?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.4.4

Products include Discourse Discourse.

How do I fix CVE-2025-48053?

Upgrade discourse to 3.4.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-48053 being exploited?

There is no known exploitation of CVE-2025-48053 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-48053, GHSA-3q5q-qmrm-rvwx.

Is CVE-2025-48053 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free