# CVE-2025-48054: Radashi Vulnerable to Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution')

> Attackers can achieve remote code execution or denial of service via prototype pollution in the set function of the Radashi library.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2025
- **Updated:** 27 May 2025
- **Also known as:** GHSA-2xv9-ghh9-xc69

## What is CVE-2025-48054?

CVE-2025-48054 is a medium-severity code injection vulnerability in radashi-org radashi, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Radashi is a TypeScript utility toolkit. Prior to version 12.5.1, the set function within the Radashi library is vulnerable to prototype pollution. If an attacker can control parts of the path argument to the set function, they could potentially modify the prototype of all objects in the JavaScript runtime, leading to unexpected behavior, denial of service, or even remote code execution in some specific scenarios. This issue has been patched in version 12.5.1. A workaround for this issue involves sanitizing the path argument provided to the set function to ensure that no part of the path string is __proto__, prototype, or constructor.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-48054?

2 open source packages ship an affected version, including radashi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `radashi` | npm | All versions | 12.5.1 |
| `radashi` | npm | All versions | 12.5.1 |

## How do I fix CVE-2025-48054?

Upgrade radashi to 12.5.1 or later.

## Is CVE-2025-48054 being exploited?

There is no known exploitation of CVE-2025-48054 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48054 and fix it if it is affected.

What it is: CVE-2025-48054 is a medium-severity code injection vulnerability in radashi-org radashi, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48054 in the wild and no public exploit code.

Affected packages and fixed versions:
- radashi (npm): affected all versions; fixed in 12.5.1
- radashi (npm): affected all versions; fixed in 12.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48054/ (Markdown: https://insights.sbomify.com/CVE-2025-48054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48054
- OSV: https://osv.dev/vulnerability/CVE-2025-48054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48054/
Summaries are generated and may contain mistakes; the official description above is the record.
