CVE-2025-48057 Icinga 2 certificate renewal might incorrectly renew an invalid certificate
Attackers can bypass certificate validation to obtain valid certificates and impersonate trusted nodes in Icinga 2 when built with older OpenSSL versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48057?
CVE-2025-48057 is a critical vulnerability in icinga2, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Icinga 2 is a monitoring system which checks the availability of network resources, notifies users of outages, and generates performance data for reporting. Prior to versions 2.12.12, 2.13.12, and 2.14.6, the VerifyCertificate() function can be tricked into incorrectly treating certificates as valid. This allows an attacker to send a malicious certificate request that is then treated as a renewal of an already existing certificate, resulting in the attacker obtaining a valid certificate that can be used to impersonate trusted nodes. This only occurs when Icinga 2 is built with OpenSSL older than version 1.1.0. This issue has been patched in versions 2.12.12, 2.13.12, and 2.14.6.
Weakness: CWE-296
Which versions are affected by CVE-2025-48057?
It affects 1 product.
Linux distribution packages (2)
icinga2 SUSE:Linux Enterprise Module for HPC 12 | All versions | 2.8.2-3.11.2 |
icinga2 openSUSE:Tumbleweed | All versions | 2.14.6-1.1 |
Products include Icinga Icinga.
How do I fix CVE-2025-48057?
Upgrade to a fixed version.
Is CVE-2025-48057 being exploited?
There is no known exploitation of CVE-2025-48057 in the wild and no public exploit code.
Other vulnerabilities in icinga2
Sources
Also known as DEBIAN-CVE-2025-48057, GHSA-7vcf-f5v9-3wr6, SUSE-SU-2025:02783-1, UBUNTU-CVE-2025-48057, openSUSE-SU-2025:15180-1.