# CVE-2025-48058: PowSyBl Core contains Polynomial REDoS’es


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Jun 2025
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-rqpx-f6rc-7hm5

## What is CVE-2025-48058?

CVE-2025-48058 is a medium-severity vulnerability in powsybl-core, published on 20 Jun 2025. 

### Official description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, there is a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the PowSyBl's DataSource mechanism. If successfully exploited, a malicious actor can cause significant CPU consumption due to regex backtracking — even with polynomial patterns. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-48058?

2 open source packages ship an affected version, including com.powsybl:powsybl-commons.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.powsybl:powsybl-commons` | Maven | All versions | 6.7.2 |
| `com.powsybl:powsybl-commons` | Maven | All versions | 6.7.2 |

## How do I fix CVE-2025-48058?

Upgrade com.powsybl:powsybl-commons to 6.7.2 or later.

## Is CVE-2025-48058 being exploited?

There is no known exploitation of CVE-2025-48058 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48058 and fix it if it is affected.

What it is: CVE-2025-48058 is a medium-severity vulnerability in powsybl-core, published on 20 Jun 2025. 
Exploitation: There is no known exploitation of CVE-2025-48058 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2
- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48058/ (Markdown: https://insights.sbomify.com/CVE-2025-48058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48058
- OSV: https://osv.dev/vulnerability/CVE-2025-48058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48058/
Summaries are generated and may contain mistakes; the official description above is the record.
