CVE-2025-48059 PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion
Attackers can cause CPU exhaustion via ReDoS in PowSyBl Core by supplying malicious regex patterns to filter operations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48059?
CVE-2025-48059 is a low-severity denial of service vulnerability in powsybl-core, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. In com.powsybl:powsybl-iidm-criteria versions 6.3.0 to before 6.7.2 and com.powsybl:powsybl-contingency-api versions 5.0.0 to before 6.3.0, there is a a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the RegexCriterion class. This class compiles and evaluates an unvalidated, user-supplied regular expression against the identifier of an Identifiable object via Pattern.compile(regex).matcher(id).find(). If successfully exploited, a malicious actor can cause significant CPU exhaustion through repeated or recursive filter(...) calls — especially if performed over large network models or filtering operations. This issue has been patched in com.powsybl:powsybl-iidm-criteria 6.7.2.
Weakness: CWE-1333
Which versions are affected by CVE-2025-48059?
4 open source packages ship an affected version, including com.powsybl:powsybl-contingency-api and com.powsybl:powsybl-iidm-criteria.
| Package | Affected | Fixed in |
|---|---|---|
com.powsybl:powsybl-contingency-api Maven | From 5.0.0 | 6.3.0 |
com.powsybl:powsybl-contingency-api Maven | From 5.0.0 | 6.3.0 |
com.powsybl:powsybl-iidm-criteria Maven | From 6.3.0 | 6.7.2 |
com.powsybl:powsybl-iidm-criteria Maven | From 6.3.0 | 6.7.2 |
How do I fix CVE-2025-48059?
Upgrade com.powsybl:powsybl-contingency-api to 6.3.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-48059 being exploited?
There is no known exploitation of CVE-2025-48059 in the wild and no public exploit code.
Sources
Also known as GHSA-8qjw-9xgm-c9ff.