# CVE-2025-48063: XWiki Platform Security Authorization Bridge allows users with just edit right can enforce required rights with programming right

> Users with edit rights can enforce programming rights, allowing escalation to remote code execution when a privileged user edits the document.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2025
- **Updated:** 21 May 2025
- **Also known as:** GHSA-rhfv-688c-p6hp

## What is CVE-2025-48063?

CVE-2025-48063 is a medium-severity vulnerability in Xwiki Xwiki, published on 21 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. In XWiki 16.10.0, required rights were introduced as a way to limit which rights a document can have. Part of the security model of required rights is that a user who doesn't have a right also cannot define that right as required right. That way, users who are editing documents on which required rights are enforced can be sure that they're not giving a right to a script or object that it didn't have before. A bug in the implementation of the enforcement of this rule means that in fact, it was possible for any user with edit right on a document to set programming right as required right. If then a user with programming right edited that document, the content of that document would gain programming right, allowing remote code execution. This thereby defeats most of the security benefits of required rights. As XWiki still performs the required rights analysis when a user edits a page even when required rights are enforced, the user with programming right would still be warned about the dangerous content unless the attacker managed to bypass this check. Note also that none of the affected versions include a UI for enabling the enforcing of required rights so it seems unlikely that anybody relied on them for security in the affected versions. As this vulnerability provides no additional attack surface unless all documents in the wiki enforce required rights, we consider the impact of this attack to be low even though gaining programming right could have a high impact. This vulnerability has been patched in XWiki 16.10.4 and 17.1.0RC1. No known workarounds are available except for upgrading.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-48063?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authorization-bridge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-authorization-bridge` | Maven | From 16.10.0-rc-1 | 16.10.4 |
| `org.xwiki.platform:xwiki-platform-security-authorization-bridge` | Maven | From 16.10.0-rc-1 | 16.10.4 |
| `org.xwiki.platform:xwiki-platform-security-authorization-bridge` | Maven | From 17.0.0-rc-1 | 17.1.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-security-authorization-bridge` | Maven | From 17.0.0-rc-1 | 17.1.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-48063?

Upgrade org.xwiki.platform:xwiki-platform-security-authorization-bridge to a fixed version for your release line: 16.10.4 or 17.1.0-rc-1.

## Is CVE-2025-48063 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48063 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48063 and fix it if it is affected.

What it is: CVE-2025-48063 is a medium-severity vulnerability in Xwiki Xwiki, published on 21 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48063 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-authorization-bridge (Maven): affected from 16.10.0-rc-1; fixed in 16.10.4
- org.xwiki.platform:xwiki-platform-security-authorization-bridge (Maven): affected from 16.10.0-rc-1; fixed in 16.10.4
- org.xwiki.platform:xwiki-platform-security-authorization-bridge (Maven): affected from 17.0.0-rc-1; fixed in 17.1.0-rc-1
- org.xwiki.platform:xwiki-platform-security-authorization-bridge (Maven): affected from 17.0.0-rc-1; fixed in 17.1.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48063/ (Markdown: https://insights.sbomify.com/CVE-2025-48063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48063
- OSV: https://osv.dev/vulnerability/CVE-2025-48063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48063/
Summaries are generated and may contain mistakes; the official description above is the record.
