CVE-2025-48068 Information exposure in Next.js dev server due to lack of origin verification

Low 2.3 Published Updated

Attackers can expose limited source code from local Next.js dev servers by tricking developers into visiting malicious pages while the App Router is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-48068?

CVE-2025-48068 is a low-severity vulnerability in Vercel Next.js, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

Weakness: CWE-1385

Which versions are affected by CVE-2025-48068?

4 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 13.014.2.30
next npmFrom 13.014.2.30
next npmFrom 15.0.015.2.2
next npmFrom 15.0.015.2.2

Products include Vercel Next.js.

How do I fix CVE-2025-48068?

Upgrade next to a fixed version for your release line: 14.2.30 or 15.2.2.

Is CVE-2025-48068 being exploited?

There is no known exploitation of CVE-2025-48068 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as GHSA-3h52-269p-cp9r, MINI-5v85-8297-m2x4, ROOT-APP-NPM-CVE-2025-48068.

Is CVE-2025-48068 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free