# CVE-2025-48068: Information exposure in Next.js dev server due to lack of origin verification

> Attackers can expose limited source code from local Next.js dev servers by tricking developers into visiting malicious pages while the App Router is enabled.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-3h52-269p-cp9r, MINI-5v85-8297-m2x4, ROOT-APP-NPM-CVE-2025-48068

## What is CVE-2025-48068?

CVE-2025-48068 is a low-severity vulnerability in Vercel Next.js, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2025-48068?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.0 | 14.2.30 |
| `next` | npm | From 13.0 | 14.2.30 |
| `next` | npm | From 15.0.0 | 15.2.2 |
| `next` | npm | From 15.0.0 | 15.2.2 |

Products: Vercel Next.js.

## How do I fix CVE-2025-48068?

Upgrade next to a fixed version for your release line: 14.2.30 or 15.2.2.

## Is CVE-2025-48068 being exploited?

There is no known exploitation of CVE-2025-48068 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48068 and fix it if it is affected.

What it is: CVE-2025-48068 is a low-severity vulnerability in Vercel Next.js, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48068 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.0; fixed in 14.2.30
- next (npm): affected from 13.0; fixed in 14.2.30
- next (npm): affected from 15.0.0; fixed in 15.2.2
- next (npm): affected from 15.0.0; fixed in 15.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48068/ (Markdown: https://insights.sbomify.com/CVE-2025-48068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48068
- OSV: https://osv.dev/vulnerability/CVE-2025-48068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48068/
Summaries are generated and may contain mistakes; the official description above is the record.
