{"answers":{"affected":"8 open source packages ship an affected version, including github.com/Shopify/ejson2env, github.com/Shopify/ejson2env/v2 and ejson2env.","exploited":"There is no known exploitation of CVE-2025-48069 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-48069 is a medium-severity command injection vulnerability in Shopify ejson2env, published on 21 May 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48069 and fix it if it is affected.\n\nWhat it is: CVE-2025-48069 is a medium-severity command injection vulnerability in Shopify ejson2env, published on 21 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48069 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/Shopify/ejson2env (Go): affected all versions; no fix listed\n- github.com/Shopify/ejson2env (Go): affected all versions; no fix listed\n- github.com/Shopify/ejson2env (Go): affected all versions; no fix listed\n- github.com/Shopify/ejson2env/v2 (Go): affected all versions; fixed in 2.0.8\n- github.com/Shopify/ejson2env/v2 (Go): affected all versions; fixed in 2.0.8\n- github.com/Shopify/ejson2env/v2 (Go): affected all versions; fixed in 2.0.8\n- ejson2env (RubyGems): affected all versions; fixed in 2.0.8\n- ejson2env (RubyGems): affected all versions; fixed in 2.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48069/ (Markdown: https://insights.sbomify.com/CVE-2025-48069/index.md)","id":"CVE-2025-48069","markdown":"https://insights.sbomify.com/CVE-2025-48069/index.md","name":"CVE-2025-48069","record":{"aliases":["GHSA-2c47-m757-32g6","GO-2025-3702"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Go secrets tool","requires_auth":"high_privilege","summary":"Insufficient output sanitization in ejson2env allows attackers to inject arbitrary commands via malicious secret values when output is executed.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"ejson2env allows users to decrypt EJSON secrets and export them as environment variables. Prior to version 2.0.8, the `ejson2env` tool has a vulnerability related to how it writes to `stdout`. Specifically, the tool is intended to write an export statement for environment variables and their values. However, due to inadequate output sanitization, there is a potential risk where variable names or values may include malicious content, resulting in additional unintended commands being output to `stdout`. If this output is improperly utilized in further command execution, it could lead to command injection, allowing an attacker to execute arbitrary commands on the host system. Version 2.0.8 sanitizes output during decryption. Other mitigations involve avoiding use of `ejson2env` to decrypt untrusted user secrets and/or avoiding evaluating or executing the direct output from `ejson2env` without removing nonprintable characters.","ecosystems":["Go","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ejson2env has insufficient input sanitization","id":"CVE-2025-48069","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":8,"n_references":2,"next":{"headline":"Plane has insecure permissions in UserSerializer","id":"CVE-2025-48070"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env","purl":null,"source":"GHSA-2c47-m757-32g6"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env","purl":"pkg:golang/github.com/Shopify/ejson2env","source":"GHSA-2c47-m757-32g6"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env","purl":"pkg:golang/github.com/Shopify/ejson2env","source":"GO-2025-3702"},{"ecosystem":"Go","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env/v2","purl":null,"source":"GHSA-2c47-m757-32g6"},{"ecosystem":"Go","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env/v2","purl":"pkg:golang/github.com/Shopify/ejson2env/v2","source":"GHSA-2c47-m757-32g6"},{"ecosystem":"Go","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"github.com/Shopify/ejson2env/v2","purl":"pkg:golang/github.com/Shopify/ejson2env/v2","source":"GO-2025-3702"},{"ecosystem":"RubyGems","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"ejson2env","purl":null,"source":"GHSA-2c47-m757-32g6"},{"ecosystem":"RubyGems","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"ejson2env","purl":"pkg:gem/ejson2env","source":"GHSA-2c47-m757-32g6"}],"prev":{"headline":"Information exposure in Next.js dev server due to lack of origin verification","id":"CVE-2025-48068"},"products":["ejson2env"],"published":"2025-05-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-21","vendors":["Shopify"]},"summary":"Insufficient output sanitization in ejson2env allows attackers to inject arbitrary commands via malicious secret values when output is executed.","url":"https://insights.sbomify.com/CVE-2025-48069/"}