# CVE-2025-48071: OpenEXR's Forged Unpacked Size can Lead to Heap-Based Buffer Overflow in Deep Scanline Parsing

> A heap-based buffer overflow in OpenEXR allows attackers to execute arbitrary code or cause denial of service via maliciously crafted EXR files.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2025
- **Updated:** 31 Jul 2025
- **Also known as:** GHSA-h45x-qhg2-q375, PYSEC-2026-1747

## What is CVE-2025-48071?

CVE-2025-48071 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 31 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.3.2 through 3.3.0, there is a heap-based buffer overflow during a write operation when decompressing ZIPS-packed deep scan-line EXR files with a maliciously forged chunk header. This is fixed in version 3.3.3.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-48071?

3 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | From 3.3.0 | 3.3.3 |
| `openexr` | PyPI | From 3.3.0 | 3.3.3 |
| `OpenEXR` | PyPI | From 3.3.0 | 3.3.3 |

Products: Openexr Openexr.

## How do I fix CVE-2025-48071?

Upgrade openexr to 3.3.3 or later.

## Is CVE-2025-48071 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48071 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48071 and fix it if it is affected.

What it is: CVE-2025-48071 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 31 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48071 exists.

Affected packages and fixed versions:
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.3
- openexr (PyPI): affected from 3.3.0; fixed in 3.3.3
- OpenEXR (PyPI): affected from 3.3.0; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48071/ (Markdown: https://insights.sbomify.com/CVE-2025-48071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48071
- OSV: https://osv.dev/vulnerability/CVE-2025-48071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48071/
Summaries are generated and may contain mistakes; the official description above is the record.
