CVE-2025-48072 OpenEXR's Inaccurate Pointer Arithmetic can Cause an Out of Bounds Heap

Medium 6.8 Published Updated

A heap-based buffer overflow in OpenEXR allows attackers to execute arbitrary code or cause denial of service via malicious EXR files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-48072?

CVE-2025-48072 is a medium-severity memory corruption vulnerability in Openexr Openexr, published on 31 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. Version 3.3.2 is vulnerable to a heap-based buffer overflow during a read operation due to bad pointer math when decompressing DWAA-packed scan-line EXR files with a maliciously forged chunk. This is fixed in version 3.3.3.

Weakness: CWE-125

Which versions are affected by CVE-2025-48072?

3 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.

PackageAffectedFixed in
openexr PyPIFrom 3.3.23.3.3
openexr PyPIFrom 3.3.23.3.3
OpenEXR PyPIFrom 3.3.23.3.3

Products include Openexr Openexr.

How do I fix CVE-2025-48072?

Upgrade openexr to 3.3.3 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-48072 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48072 exists.

All Openexr Openexr vulnerabilities

Sources

Also known as GHSA-4r7w-q3jg-ff43, PYSEC-2026-1746, UBUNTU-CVE-2025-48072.

Is CVE-2025-48072 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free