# CVE-2025-48075: Fiber panics when fiber.Ctx.BodyParser parses invalid range index

> An attacker can cause a denial of service by sending negative range indices to the BodyParser function in the Fiber Go web framework.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2025
- **Updated:** 22 May 2025
- **Also known as:** GHSA-hg3g-gphw-5hhm, GO-2025-3706

## What is CVE-2025-48075?

CVE-2025-48075 is a high-severity denial of service vulnerability in gofiber fiber, published on 22 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an Express-inspired web framework written in Go. Starting in version 2.52.6 and prior to version 2.52.7, `fiber.Ctx.BodyParser` can map flat data to nested slices using `key[idx]value` syntax, but when idx is negative, it causes a panic instead of returning an error stating it cannot process the data. Since this data is user-provided, this could lead to denial of service for anyone relying on this `fiber.Ctx.BodyParser`  functionality. Version 2.52.7 fixes the issue.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2025-48075?

4 open source packages ship an affected version, including github.com/gofiber/fiber/v2 and github.com/gofiber/fiber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | From 2.52.6 | 2.52.7 |
| `github.com/gofiber/fiber/v2` | Go | From 2.52.6 | 2.52.7 |
| `github.com/gofiber/fiber/v2` | Go | From 2.52.6 | 2.52.7 |
| `github.com/gofiber/fiber` | Go | All versions | None |

Products: Gofiber Fiber.

## How do I fix CVE-2025-48075?

Upgrade github.com/gofiber/fiber/v2 to 2.52.7 or later.

## Is CVE-2025-48075 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48075 exists.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48075 and fix it if it is affected.

What it is: CVE-2025-48075 is a high-severity denial of service vulnerability in gofiber fiber, published on 22 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48075 exists.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected from 2.52.6; fixed in 2.52.7
- github.com/gofiber/fiber/v2 (Go): affected from 2.52.6; fixed in 2.52.7
- github.com/gofiber/fiber/v2 (Go): affected from 2.52.6; fixed in 2.52.7
- github.com/gofiber/fiber (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48075/ (Markdown: https://insights.sbomify.com/CVE-2025-48075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48075
- OSV: https://osv.dev/vulnerability/CVE-2025-48075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48075/
Summaries are generated and may contain mistakes; the official description above is the record.
