CVE-2025-48076 Galette is vulnerable to Cross-site Scripting

Medium 5.3 Published Updated

Attackers can inject malicious scripts via group names in Galette, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-48076?

CVE-2025-48076 is a medium-severity cross-site scripting vulnerability in galette, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Galette is a membership management web application for non profit organizations. Versions 1.1.5.2 and below allow a user to edit a group name and insert an XSS payload. This issue is fixed in version 1.2.0.

Weakness: CWE-79, CWE-87

Which versions are affected by CVE-2025-48076?

It affects 1 product.

Products include Galette Galette.

How do I fix CVE-2025-48076?

No fix has been published for CVE-2025-48076 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-48076 being exploited?

There is no known exploitation of CVE-2025-48076 in the wild and no public exploit code.

Sources

Also known as GHSA-ccwq-mxx3-chvh, UBUNTU-CVE-2025-48076.

Is CVE-2025-48076 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free