# CVE-2025-48200: The Front End User Registration extension for TYPO3 (sr_feuser_register) Remote Code Execution

> An attacker can achieve remote code execution via unsafe deserialization in the sr_feuser_register extension for TYPO3.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2025
- **Updated:** 22 May 2025
- **Also known as:** GHSA-qfm8-78qf-p75j

## What is CVE-2025-48200?

CVE-2025-48200 is a critical unsafe deserialization vulnerability in TYPO3 sr feuser register extension, published on 21 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The sr_feuser_register extension through 12.4.8 for TYPO3 allows Remote Code Execution.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-48200?

2 open source packages ship an affected version, including sjbr/sr-feuser-register.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sjbr/sr-feuser-register` | Packagist | From 5.1.0 | 12.5.0 |
| `sjbr/sr-feuser-register` | Packagist | From 5.1.0 | 12.5.0 |

## How do I fix CVE-2025-48200?

Upgrade sjbr/sr-feuser-register to 12.5.0 or later.

## Is CVE-2025-48200 being exploited?

There is no known exploitation of CVE-2025-48200 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48200 and fix it if it is affected.

What it is: CVE-2025-48200 is a critical unsafe deserialization vulnerability in TYPO3 sr feuser register extension, published on 21 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48200 in the wild and no public exploit code.

Affected packages and fixed versions:
- sjbr/sr-feuser-register (Packagist): affected from 5.1.0; fixed in 12.5.0
- sjbr/sr-feuser-register (Packagist): affected from 5.1.0; fixed in 12.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48200/ (Markdown: https://insights.sbomify.com/CVE-2025-48200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48200
- OSV: https://osv.dev/vulnerability/CVE-2025-48200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48200/
Summaries are generated and may contain mistakes; the official description above is the record.
