CVE-2025-48203 [clickstorm] SEO (cs_seo) TYPO3 extension Cross-site Scripting (XSS) vulnerability
Cross-site scripting vulnerability in the cs_seo extension for TYPO3 allows attackers to inject malicious scripts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48203?
CVE-2025-48203 is a medium-severity cross-site scripting vulnerability in TYPO3 cs seo extension, published on 21 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The cs_seo extension through 9.2.0 for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2025-48203?
8 open source packages ship an affected version, including clickstorm/cs-seo.
| Package | Affected | Fixed in |
|---|---|---|
clickstorm/cs-seo Packagist | From 6.3.0 | 6.8.0 |
clickstorm/cs-seo Packagist | From 6.3.0 | 6.8.0 |
clickstorm/cs-seo Packagist | From 7.0.0 | 7.5.0 |
clickstorm/cs-seo Packagist | From 7.0.0 | 7.5.0 |
clickstorm/cs-seo Packagist | From 8.0.0 | 8.4.0 |
clickstorm/cs-seo Packagist | From 8.0.0 | 8.4.0 |
2 more packages
clickstorm/cs-seo Packagist | From 9.0.0 | 9.3.0 |
clickstorm/cs-seo Packagist | From 9.0.0 | 9.3.0 |
How do I fix CVE-2025-48203?
Upgrade clickstorm/cs-seo to a fixed version for your release line: 6.8.0, 7.5.0, 8.4.0 or 9.3.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-48203 being exploited?
There is no known exploitation of CVE-2025-48203 in the wild and no public exploit code.
Sources
Also known as GHSA-6p8w-pc35-mqv8.