# CVE-2025-48206: The Backup Plus extension for TYPO3 (ns_backup) allows XSS

> Cross-site scripting vulnerability in the ns_backup extension for TYPO3 allows attackers to inject malicious scripts.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2025
- **Updated:** 21 May 2025
- **Also known as:** GHSA-xg53-mhh9-3cq7

## What is CVE-2025-48206?

CVE-2025-48206 is a medium-severity cross-site scripting vulnerability in TYPO3 ns backup extension, published on 21 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The ns_backup extension through 13.0.0 for TYPO3 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-48206?

2 open source packages ship an affected version, including nitsan/ns-backup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nitsan/ns-backup` | Packagist | All versions | 13.0.1 |
| `nitsan/ns-backup` | Packagist | All versions | 13.0.1 |

Products: Nitsantech Ns-Backup.

## How do I fix CVE-2025-48206?

Upgrade nitsan/ns-backup to 13.0.1 or later.

## Is CVE-2025-48206 being exploited?

There is no known exploitation of CVE-2025-48206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48206 and fix it if it is affected.

What it is: CVE-2025-48206 is a medium-severity cross-site scripting vulnerability in TYPO3 ns backup extension, published on 21 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48206 in the wild and no public exploit code.

Affected packages and fixed versions:
- nitsan/ns-backup (Packagist): affected all versions; fixed in 13.0.1
- nitsan/ns-backup (Packagist): affected all versions; fixed in 13.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48206/ (Markdown: https://insights.sbomify.com/CVE-2025-48206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48206
- OSV: https://osv.dev/vulnerability/CVE-2025-48206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48206/
Summaries are generated and may contain mistakes; the official description above is the record.
