CVE-2025-48208 Apache HertzBeat (incubating): Jmx JNDI injection vulnerability

High 8.8 Published Updated

Authenticated attackers can execute arbitrary scripts via JNDI injection in Apache HertzBeat, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-48208?

CVE-2025-48208 is a high-severity code injection vulnerability in Apache HertzBeat (incubating), published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache HertzBeat .

The attacker needs to have an authenticated account with access, and the attack can only be triggered by crafting custom commands. A successful attack would result in arbitrary script execution.

This issue affects Apache HertzBeat: through 1.7.2.

Users are recommended to upgrade to version [1.7.3], which fixes the issue.

Weakness: CWE-90

Which versions are affected by CVE-2025-48208?

It affects 1 product.

Products include Apache Hertzbeat.

How do I fix CVE-2025-48208?

No fix has been published for CVE-2025-48208 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-48208 being exploited?

There is no known exploitation of CVE-2025-48208 in the wild and no public exploit code.

Sources

Also known as GHSA-q6jp-29q3-rwxv.

Is CVE-2025-48208 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free