{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-48208 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-48208 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-48208 is a high-severity code injection vulnerability in Apache HertzBeat (incubating), published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48208 and fix it if it is affected.\n\nWhat it is: CVE-2025-48208 is a high-severity code injection vulnerability in Apache HertzBeat (incubating), published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48208 in the wild and no public exploit code.\n\nAffected product: Apache HertzBeat (incubating). No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48208/ (Markdown: https://insights.sbomify.com/CVE-2025-48208/index.md)","id":"CVE-2025-48208","markdown":"https://insights.sbomify.com/CVE-2025-48208/index.md","name":"CVE-2025-48208","record":{"aliases":["GHSA-q6jp-29q3-rwxv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HertzBeat monitoring","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary scripts via JNDI injection in Apache HertzBeat, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hertzbeat","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-90","name":"Improper Neutralization of Special Elements used in an LDAP Query"}],"description":"Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache HertzBeat .\n\nThe attacker needs to have an authenticated account with access, and the attack can only be triggered by crafting custom commands. A successful attack would result in arbitrary script execution.\n\nThis issue affects Apache HertzBeat: through 1.7.2.\n\nUsers are recommended to upgrade to version [1.7.3], which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache HertzBeat (incubating): Jmx JNDI injection vulnerability","id":"CVE-2025-48208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Information disclosure in O2","id":"CVE-2025-48219"},"packages":[],"prev":{"headline":"reint_downloadmanager TYPO3 Extension is susceptible to Insecure Direct Object Reference","id":"CVE-2025-48207"},"products":["Apache HertzBeat (incubating)"],"published":"2025-09-09","related":[{"cvss_score":9.8,"headline":"HertzBeat AviatorScript Inject RCE","id":"CVE-2023-51388","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":9.8,"headline":"HertzBeat SnakeYAML Deser RCE","id":"CVE-2023-51389","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":9.8,"headline":"Hertzbeat JMX JNDI RCE","id":"CVE-2023-51653","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.8,"headline":"Apache HertzBeat: Uncontrolled Resource Consumption via Crafted XPath Expressions","id":"CVE-2026-24343","kev_date_added":null,"published":"2026-02-10"},{"cvss_score":8.8,"headline":"Apache HertzBeat (incubating): RCE by parse http sitemap xml response","id":"CVE-2025-24404","kev_date_added":null,"published":"2025-09-09"},{"cvss_score":8.8,"headline":"Apache HertzBeat: RCE by notice template injection vulnerability","id":"CVE-2024-41151","kev_date_added":null,"published":"2024-11-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Authenticated attackers can execute arbitrary scripts via JNDI injection in Apache HertzBeat, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-48208/"}