{"answers":{"affected":"2 open source packages ship an affected version, including @supabase/auth-js.","exploited":"There is no known exploitation of CVE-2025-48370 in the wild and no public exploit code.","fix":"Upgrade @supabase/auth-js to 2.70.0 or later.","what":"CVE-2025-48370 is a low-severity path traversal vulnerability in supabase auth-js, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48370 and fix it if it is affected.\n\nWhat it is: CVE-2025-48370 is a low-severity path traversal vulnerability in supabase auth-js, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48370 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @supabase/auth-js (npm): affected all versions; fixed in 2.70.0\n- @supabase/auth-js (npm): affected all versions; fixed in 2.70.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48370/ (Markdown: https://insights.sbomify.com/CVE-2025-48370/index.md)","id":"CVE-2025-48370","markdown":"https://insights.sbomify.com/CVE-2025-48370/index.md","name":"CVE-2025-48370","record":{"aliases":["GHSA-8r88-6cj9-9fh5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Supabase Auth library","requires_auth":"none","summary":"Attackers can exploit malformed user input to bypass authentication checks and modify data via path traversal in Supabase Auth library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"auth-js Vulnerable to Insecure Path Routing from Malformed User Input","id":"CVE-2025-48370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"OpenFGA Authorization Bypass","id":"CVE-2025-48371"},"packages":[{"ecosystem":"npm","fixed":["2.70.0"],"introduced":["0"],"last_affected":[],"package":"@supabase/auth-js","purl":null,"source":"GHSA-8r88-6cj9-9fh5"},{"ecosystem":"npm","fixed":["2.70.0"],"introduced":["0"],"last_affected":[],"package":"@supabase/auth-js","purl":"pkg:npm/%40supabase/auth-js","source":"GHSA-8r88-6cj9-9fh5"}],"prev":{"headline":"GroupOffice vulnerable to Stored XSS in Tasks Comment Section","id":"CVE-2025-48369"},"products":["auth-js"],"published":"2025-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-27","vendors":["supabase"]},"summary":"Attackers can exploit malformed user input to bypass authentication checks and modify data via path traversal in Supabase Auth library.","url":"https://insights.sbomify.com/CVE-2025-48370/"}