# CVE-2025-48370: auth-js Vulnerable to Insecure Path Routing from Malformed User Input

> Attackers can exploit malformed user input to bypass authentication checks and modify data via path traversal in Supabase Auth library.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2025
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-8r88-6cj9-9fh5

## What is CVE-2025-48370?

CVE-2025-48370 is a low-severity path traversal vulnerability in supabase auth-js, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

Weakness: CWE-287 (Improper Authentication), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-48370?

2 open source packages ship an affected version, including @supabase/auth-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@supabase/auth-js` | npm | All versions | 2.70.0 |
| `@supabase/auth-js` | npm | All versions | 2.70.0 |

## How do I fix CVE-2025-48370?

Upgrade @supabase/auth-js to 2.70.0 or later.

## Is CVE-2025-48370 being exploited?

There is no known exploitation of CVE-2025-48370 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48370 and fix it if it is affected.

What it is: CVE-2025-48370 is a low-severity path traversal vulnerability in supabase auth-js, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48370 in the wild and no public exploit code.

Affected packages and fixed versions:
- @supabase/auth-js (npm): affected all versions; fixed in 2.70.0
- @supabase/auth-js (npm): affected all versions; fixed in 2.70.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48370/ (Markdown: https://insights.sbomify.com/CVE-2025-48370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48370
- OSV: https://osv.dev/vulnerability/CVE-2025-48370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48370/
Summaries are generated and may contain mistakes; the official description above is the record.
