CVE-2025-48371 OpenFGA Authorization Bypass
Attackers can bypass authorization checks in OpenFGA under specific model and query conditions, potentially gaining unauthorized access to resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48371?
CVE-2025-48371 is a medium-severity authentication bypass vulnerability in openfga, published on 22 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
Weakness: CWE-285
Which versions are affected by CVE-2025-48371?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | From 1.8.0 | 1.8.13 |
github.com/openfga/openfga Go | From 1.8.0 | 1.8.13 |
github.com/openfga/openfga Go | From 1.8.0 | 1.8.13 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2025-48371?
Upgrade github.com/openfga/openfga to 1.8.13 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-48371 being exploited?
There is no known exploitation of CVE-2025-48371 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-c72g-53hw-82q7, GO-2025-3707, MINI-4q9x-h4m2-3xf4, MINI-cjc5-4977-r637, MINI-fgjw-pfr8-5h49, MINI-qj29-fhjv-hw3g.