# CVE-2025-48371: OpenFGA Authorization Bypass

> Attackers can bypass authorization checks in OpenFGA under specific model and query conditions, potentially gaining unauthorized access to resources.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2025
- **Updated:** 23 May 2025
- **Also known as:** GHSA-c72g-53hw-82q7, GO-2025-3707, MINI-4q9x-h4m2-3xf4, MINI-cjc5-4977-r637, MINI-fgjw-pfr8-5h49, MINI-qj29-fhjv-hw3g

## What is CVE-2025-48371?

CVE-2025-48371 is a medium-severity authentication bypass vulnerability in openfga, published on 22 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-48371?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.8.13 |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.8.13 |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.8.13 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2025-48371?

Upgrade github.com/openfga/openfga to 1.8.13 or later.

## Is CVE-2025-48371 being exploited?

There is no known exploitation of CVE-2025-48371 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-46331](https://insights.sbomify.com/CVE-2025-46331/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48371 and fix it if it is affected.

What it is: CVE-2025-48371 is a medium-severity authentication bypass vulnerability in openfga, published on 22 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48371 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.8.13
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.8.13
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.8.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48371/ (Markdown: https://insights.sbomify.com/CVE-2025-48371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48371
- OSV: https://osv.dev/vulnerability/CVE-2025-48371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48371/
Summaries are generated and may contain mistakes; the official description above is the record.
