CVE-2025-48379 Pillow Vulnerable to Write Buffer Overflow on BCn encoding
A heap buffer overflow in Pillow allows attackers to execute arbitrary code or cause denial of service when saving large untrusted DDS images.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48379?
CVE-2025-48379 is a high-severity memory corruption vulnerability in Python Pillow, published on 1 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Pillow is a Python imaging library. In versions 11.2.0 to before 11.3.0, there is a heap buffer overflow when writing a sufficiently large (>64k encoded with default settings) image in the DDS format due to writing into a buffer without checking for available space. This only affects users who save untrusted data as a compressed DDS image. This issue has been patched in version 11.3.0.
Weakness: CWE-122
Which versions are affected by CVE-2025-48379?
4 open source packages ship an affected version, including pillow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pillow Bitnami | From 11.2.0 | None |
pillow PyPI | From 11.2.0 | 11.3.0 |
pillow PyPI | From 11.2.0 | 11.3.0 |
pillow PyPI | From 11.2.0 | 11.3.0 |
Linux distribution packages (1)
python-Pillow openSUSE:Tumbleweed | All versions | 11.3.0-1.1 |
Products include Python Pillow.
How do I fix CVE-2025-48379?
Upgrade pillow to 11.3.0 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-48379 being exploited?
There is no known exploitation of CVE-2025-48379 in the wild and no public exploit code.
Other vulnerabilities in Python Pillow
Sources
Also known as BIT-pillow-2025-48379, CLSA-2026-1772410259, GHSA-xg8h-j46f-w952, PYSEC-2025-61, ROOT-APP-PYPI-CVE-2025-48379, openSUSE-SU-2025:15316-1.