CVE-2025-48385 Git alllows arbitrary file writes via bundle-uri parameter injection

High 8.6 Published Updated

Git allows arbitrary file writes via bundle-uri injection, potentially leading to code execution when cloning malicious repositories with bundle URIs enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-48385?

CVE-2025-48385 is a high-severity path traversal vulnerability in git, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Weakness: CWE-88, CWE-73

Which versions are affected by CVE-2025-48385?

1 open source package ship an affected version, including git.

PackageAffectedFixed in
git BitnamiAll versions2.50.1

How do I fix CVE-2025-48385?

Upgrade git to 2.50.1 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-48385 being exploited?

There is no known exploitation of CVE-2025-48385 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2025-48385, AZL-65040, AZL-65051, BELL-CVE-2025-48385, BIT-git-2025-48385, CLSA-2025-1752576917 and 7 more.

Is CVE-2025-48385 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free