{"answers":{"affected":"1 open source package ship an affected version, including git.","exploited":"There is no known exploitation of CVE-2025-48385 in the wild and no public exploit code.","fix":"Upgrade git to 2.50.1 or later.","what":"CVE-2025-48385 is a high-severity path traversal vulnerability in git, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-48385 and fix it if it is affected.\n\nWhat it is: CVE-2025-48385 is a high-severity path traversal vulnerability in git, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-48385 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git (Bitnami): affected all versions; fixed in 2.50.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48385/ (Markdown: https://insights.sbomify.com/CVE-2025-48385/index.md)","id":"CVE-2025-48385","markdown":"https://insights.sbomify.com/CVE-2025-48385/index.md","name":"CVE-2025-48385","record":{"aliases":["ALPINE-CVE-2025-48385","AZL-65040","AZL-65051","BELL-CVE-2025-48385","BIT-git-2025-48385","CLSA-2025-1752576917","CLSA-2025-1753729385","DEBIAN-CVE-2025-48385","ECHO-228d-675d-8bf1","GHSA-m98c-vgpc-9655","MINI-58pm-m586-rj2q","ROOT-OS-DEBIAN-12-CVE-2025-48385","UBUNTU-CVE-2025-48385"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Git version control","requires_auth":"none","summary":"Git allows arbitrary file writes via bundle-uri injection, potentially leading to code execution when cloning malicious repositories with bundle URIs enabled.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-73","name":"External Control of File Name or Path"}],"description":"Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Git alllows arbitrary file writes via bundle-uri parameter injection","id":"CVE-2025-48385","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Git allows a buffer overflow in 'wincred' credential helper","id":"CVE-2025-48386"},"packages":[{"ecosystem":"Bitnami","fixed":["2.50.1"],"introduced":["0"],"last_affected":[],"package":"git","purl":"pkg:bitnami/git","source":"BIT-git-2025-48385"}],"prev":{"headline":"Git Link Following","id":"CVE-2025-48384"},"products":["git"],"published":"2025-07-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["git"]},"summary":"Git allows arbitrary file writes via bundle-uri injection, potentially leading to code execution when cloning malicious repositories with bundle URIs enabled.","url":"https://insights.sbomify.com/CVE-2025-48385/"}