# CVE-2025-48385: Git alllows arbitrary file writes via bundle-uri parameter injection

> Git allows arbitrary file writes via bundle-uri injection, potentially leading to code execution when cloning malicious repositories with bundle URIs enabled.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-48385, AZL-65040, AZL-65051, BELL-CVE-2025-48385, BIT-git-2025-48385, CLSA-2025-1752576917, CLSA-2025-1753729385, DEBIAN-CVE-2025-48385, ECHO-228d-675d-8bf1, GHSA-m98c-vgpc-9655, MINI-58pm-m586-rj2q, ROOT-OS-DEBIAN-12-CVE-2025-48385, UBUNTU-CVE-2025-48385

## What is CVE-2025-48385?

CVE-2025-48385 is a high-severity path traversal vulnerability in git, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-48385?

1 open source package ship an affected version, including git.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git` | Bitnami | All versions | 2.50.1 |

## How do I fix CVE-2025-48385?

Upgrade git to 2.50.1 or later.

## Is CVE-2025-48385 being exploited?

There is no known exploitation of CVE-2025-48385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48385 and fix it if it is affected.

What it is: CVE-2025-48385 is a high-severity path traversal vulnerability in git, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48385 in the wild and no public exploit code.

Affected packages and fixed versions:
- git (Bitnami): affected all versions; fixed in 2.50.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48385/ (Markdown: https://insights.sbomify.com/CVE-2025-48385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48385
- OSV: https://osv.dev/vulnerability/CVE-2025-48385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48385/
Summaries are generated and may contain mistakes; the official description above is the record.
