{"answers":{"affected":"1 open source package ship an affected version, including git.","exploited":"There is no known exploitation of CVE-2025-48386 in the wild and no public exploit code.","fix":"Upgrade git to 2.50.1 or later.","what":"CVE-2025-48386 is a medium-severity memory corruption vulnerability in git, published on 8 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-48386 and fix it if it is affected.\n\nWhat it is: CVE-2025-48386 is a medium-severity memory corruption vulnerability in git, published on 8 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-48386 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git (Bitnami): affected all versions; fixed in 2.50.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48386/ (Markdown: https://insights.sbomify.com/CVE-2025-48386/index.md)","id":"CVE-2025-48386","markdown":"https://insights.sbomify.com/CVE-2025-48386/index.md","name":"CVE-2025-48386","record":{"aliases":["ALPINE-CVE-2025-48386","BELL-CVE-2025-48386","BIT-git-2025-48386","CLSA-2025-1754939966","CLSA-2025-1755113387","ECHO-5b87-846d-45a5","GHSA-4v56-3xvj-xvfr","MINI-66qv-qjhf-p8mr","UBUNTU-CVE-2025-48386"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Git version control","requires_auth":"none","summary":"A buffer overflow in Git's wincred credential helper allows attackers to execute arbitrary code via improper bounds checking.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Git allows a buffer overflow in 'wincred' credential helper","id":"CVE-2025-48386","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"tar-fs has issue where extract can write outside the specified dir with a specific tarball","id":"CVE-2025-48387"},"packages":[{"ecosystem":"Bitnami","fixed":["2.50.1"],"introduced":["0"],"last_affected":[],"package":"git","purl":"pkg:bitnami/git","source":"BIT-git-2025-48386"}],"prev":{"headline":"Git alllows arbitrary file writes via bundle-uri parameter injection","id":"CVE-2025-48385"},"products":["git"],"published":"2025-07-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["git"]},"summary":"A buffer overflow in Git's wincred credential helper allows attackers to execute arbitrary code via improper bounds checking.","url":"https://insights.sbomify.com/CVE-2025-48386/"}