# CVE-2025-48386: Git allows a buffer overflow in 'wincred' credential helper

> A buffer overflow in Git's wincred credential helper allows attackers to execute arbitrary code via improper bounds checking.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-48386, BELL-CVE-2025-48386, BIT-git-2025-48386, CLSA-2025-1754939966, CLSA-2025-1755113387, ECHO-5b87-846d-45a5, GHSA-4v56-3xvj-xvfr, MINI-66qv-qjhf-p8mr, UBUNTU-CVE-2025-48386

## What is CVE-2025-48386?

CVE-2025-48386 is a medium-severity memory corruption vulnerability in git, published on 8 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2025-48386?

1 open source package ship an affected version, including git.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git` | Bitnami | All versions | 2.50.1 |

## How do I fix CVE-2025-48386?

Upgrade git to 2.50.1 or later.

## Is CVE-2025-48386 being exploited?

There is no known exploitation of CVE-2025-48386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48386 and fix it if it is affected.

What it is: CVE-2025-48386 is a medium-severity memory corruption vulnerability in git, published on 8 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48386 in the wild and no public exploit code.

Affected packages and fixed versions:
- git (Bitnami): affected all versions; fixed in 2.50.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48386/ (Markdown: https://insights.sbomify.com/CVE-2025-48386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48386
- OSV: https://osv.dev/vulnerability/CVE-2025-48386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48386/
Summaries are generated and may contain mistakes; the official description above is the record.
