{"answers":{"affected":"6 open source packages ship an affected version, including tar-fs.","exploited":"There is no known exploitation of CVE-2025-48387 in the wild and no public exploit code.","fix":"Upgrade tar-fs to a fixed version for your release line: 1.16.5, 2.1.3 or 3.0.9.","what":"CVE-2025-48387 is a high-severity path traversal vulnerability in mafintosh tar-fs, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48387 and fix it if it is affected.\n\nWhat it is: CVE-2025-48387 is a high-severity path traversal vulnerability in mafintosh tar-fs, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48387 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tar-fs (npm): affected all versions; fixed in 1.16.5\n- tar-fs (npm): affected all versions; fixed in 1.16.5\n- tar-fs (npm): affected from 2.0.0; fixed in 2.1.3\n- tar-fs (npm): affected from 2.0.0; fixed in 2.1.3\n- tar-fs (npm): affected from 3.0.0; fixed in 3.0.9\n- tar-fs (npm): affected from 3.0.0; fixed in 3.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48387/ (Markdown: https://insights.sbomify.com/CVE-2025-48387/index.md)","id":"CVE-2025-48387","markdown":"https://insights.sbomify.com/CVE-2025-48387/index.md","name":"CVE-2025-48387","record":{"aliases":["AZL-62236","DEBIAN-CVE-2025-48387","ECHO-bd2e-0f41-afca","GHSA-8cj5-5rvv-wf4v","MINI-6v26-v72m-jxpp","MINI-ffp8-j64x-9672","MINI-gxc4-x47f-r8cf","MINI-q48m-jh7x-cqq2","ROOT-APP-NPM-CVE-2025-48387","UBUNTU-CVE-2025-48387"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js tar library","requires_auth":"none","summary":"Attackers can write files outside the intended directory using a malicious tarball, affecting applications using the tar-fs library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.0.9, 2.1.3, and 1.16.5 have an issue where an extract can write outside the specified dir with a specific tarball. This has been patched in versions 3.0.9, 2.1.3, and 1.16.5. As a workaround, use the ignore option to ignore non files/directories.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tar-fs has issue where extract can write outside the specified dir with a specific tarball","id":"CVE-2025-48387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"FreeScout Has Insufficient Protection Against CRLF-injection","id":"CVE-2025-48388"},"packages":[{"ecosystem":"npm","fixed":["1.16.5"],"introduced":["0"],"last_affected":[],"package":"tar-fs","purl":null,"source":"GHSA-8cj5-5rvv-wf4v"},{"ecosystem":"npm","fixed":["1.16.5"],"introduced":["0"],"last_affected":[],"package":"tar-fs","purl":"pkg:npm/tar-fs","source":"GHSA-8cj5-5rvv-wf4v"},{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["2.0.0"],"last_affected":[],"package":"tar-fs","purl":null,"source":"GHSA-8cj5-5rvv-wf4v"},{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["2.0.0"],"last_affected":[],"package":"tar-fs","purl":"pkg:npm/tar-fs","source":"GHSA-8cj5-5rvv-wf4v"},{"ecosystem":"npm","fixed":["3.0.9"],"introduced":["3.0.0"],"last_affected":[],"package":"tar-fs","purl":null,"source":"GHSA-8cj5-5rvv-wf4v"},{"ecosystem":"npm","fixed":["3.0.9"],"introduced":["3.0.0"],"last_affected":[],"package":"tar-fs","purl":"pkg:npm/tar-fs","source":"GHSA-8cj5-5rvv-wf4v"}],"prev":{"headline":"Git allows a buffer overflow in 'wincred' credential helper","id":"CVE-2025-48386"},"products":["tar-fs"],"published":"2025-06-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["mafintosh"]},"summary":"Attackers can write files outside the intended directory using a malicious tarball, affecting applications using the tar-fs library.","url":"https://insights.sbomify.com/CVE-2025-48387/"}