CVE-2025-48392 Apache IoTDB: DoS Vulnerability

High 7.5 Published Updated

Attackers can cause a denial of service in Apache IoTDB, requiring users to upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48392?

CVE-2025-48392 is a high-severity denial of service vulnerability in Apache IoTDB, published on 24 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability in Apache IoTDB.

This issue affects Apache IoTDB: from 1.3.3 through 1.3.4, from 2.0.1-beta through 2.0.4.

Users are recommended to upgrade to version 2.0.5, which fixes the issue.

Weakness: CWE-400

Which versions are affected by CVE-2025-48392?

2 open source packages ship an affected version, including org.apache.iotdb:iotdb-core. It affects 1 product.

PackageAffectedFixed in
org.apache.iotdb:iotdb-core MavenFrom 1.3.32.0.5
org.apache.iotdb:iotdb-core MavenFrom 1.3.32.0.5

Products include Apache Iotdb.

How do I fix CVE-2025-48392?

Upgrade org.apache.iotdb:iotdb-core to 2.0.5 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-48392 being exploited?

There is no known exploitation of CVE-2025-48392 in the wild and no public exploit code.

Sources

Also known as GHSA-vx84-xvr8-w24c.

Is CVE-2025-48392 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free