# CVE-2025-48431: Apache Thrift: Specially crafted input can crash a c_glib Thrift server with invalid pointer error.


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 10 Sep 2026
- **Also known as:** AZL-85014, BIT-thrift-2025-48431, DEBIAN-CVE-2025-48431, ECHO-d017-aa78-89cb, GHSA-ppv5-592p-g5q4, UBUNTU-CVE-2025-48431

## What is CVE-2025-48431?

CVE-2025-48431 is a high-severity vulnerability in Apache Thrift, published on 28 Apr 2026. 

### Official description

Mismatched Memory Management Routines vulnerability in Apache Thrift c_glib language bindings.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Description: Specially crafted requests can crash an c_glib-based Thrift server with a clean but fatal "free(): invalid pointer" error message.

Weakness: CWE-763 (Release of Invalid Pointer or Reference), CWE-762 (Mismatched Memory Management Routines)

## Which versions are affected by CVE-2025-48431?

1 open source package ship an affected version, including thrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.23.0 |

Products: Apache Thrift.

## How do I fix CVE-2025-48431?

Upgrade thrift to 0.23.0 or later.

## Is CVE-2025-48431 being exploited?

There is no known exploitation of CVE-2025-48431 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48431 and fix it if it is affected.

What it is: CVE-2025-48431 is a high-severity vulnerability in Apache Thrift, published on 28 Apr 2026. 
Exploitation: There is no known exploitation of CVE-2025-48431 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48431/ (Markdown: https://insights.sbomify.com/CVE-2025-48431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48431
- OSV: https://osv.dev/vulnerability/CVE-2025-48431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48431/
Summaries are generated and may contain mistakes; the official description above is the record.
