# CVE-2025-48432: Django Improper Output Neutralization for Logs vulnerability

> Remote attackers can manipulate Django HTTP response logs via crafted URLs, potentially causing log injection or forgery in terminal or external log viewers.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2025
- **Updated:** 11 Jun 2025
- **Also known as:** BIT-django-2025-48432, CLSA-2025-1754352705, CLSA-2025-1762301491, CLSA-2026-1789475453, DEBIAN-CVE-2025-48432, ECHO-5ac0-dab3-bd4d, GHSA-7xr5-9hcq-chf9, MGASA-2025-0193, OESA-2025-1617, OESA-2025-1618, OESA-2025-1619, OESA-2025-1642, OESA-2025-1643, PYSEC-2025-47, ROOT-APP-PYPI-CVE-2025-48432, SUSE-SU-2025:01952-1, SUSE-SU-2025:02248-1, UBUNTU-CVE-2025-48432, USN-7555-1, USN-7555-2, openSUSE-SU-2025:15267-1, openSUSE-SU-2025:15268-1

## What is CVE-2025-48432?

CVE-2025-48432 is a medium-severity vulnerability in Debian Debian Linux, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 5.2 before 5.2.3, 5.1 before 5.1.11, and 4.2 before 4.2.23. Internal HTTP response logging does not escape request.path, which allows remote attackers to potentially manipulate log output via crafted URLs. This may lead to log injection or forgery when logs are viewed in terminals or processed by external systems.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2025-48432?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.23, 5.1.11, 5.2.3 |
| `django` | PyPI | All versions | 4.2.22 |
| `django` | PyPI | From 5.0a1 | 5.1.10 |
| `django` | PyPI | From 5.2 | 5.2.2, 5.1.10, 4.2.22 |
| `django` | PyPI | From 5.2 | 5.2.2 |
| `Django` | PyPI | All versions | 4.2.22 |
| `Django` | PyPI | From 5.0a1 | 5.1.10 |
| `Django` | PyPI | From 5.2 | 5.2.2 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.24.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.27.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.24.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.27.1 |
| `python-Django` | openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.24.1 |
| `python-Django` | openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.27.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.2.2-1.1 |
| `python-Django4` | openSUSE:Tumbleweed | All versions | 4.2.22-1.1 |

Products: Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2025-48432?

Upgrade django to a fixed version for your release line: 4.2.23, 5.1.11, 5.2.3 or 4.2.22.

## Is CVE-2025-48432 being exploited?

There is no known exploitation of CVE-2025-48432 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48432 and fix it if it is affected.

What it is: CVE-2025-48432 is a medium-severity vulnerability in Debian Debian Linux, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48432 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.23, 5.1.11, 5.2.3
- django (PyPI): affected all versions; fixed in 4.2.22
- django (PyPI): affected from 5.0a1; fixed in 5.1.10
- django (PyPI): affected from 5.2; fixed in 5.2.2, 5.1.10, 4.2.22
- django (PyPI): affected from 5.2; fixed in 5.2.2
- Django (PyPI): affected all versions; fixed in 4.2.22
- Django (PyPI): affected from 5.0a1; fixed in 5.1.10
- Django (PyPI): affected from 5.2; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48432/ (Markdown: https://insights.sbomify.com/CVE-2025-48432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48432
- OSV: https://osv.dev/vulnerability/CVE-2025-48432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48432/
Summaries are generated and may contain mistakes; the official description above is the record.
