{"answers":{"affected":"2 open source packages ship an affected version, including drupal/lightgallery. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-48447 in the wild and no public exploit code.","fix":"Upgrade drupal/lightgallery to 1.6.0 or later.","what":"CVE-2025-48447 is a high-severity cross-site scripting vulnerability in Drupal Lightgallery, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48447 and fix it if it is affected.\n\nWhat it is: CVE-2025-48447 is a high-severity cross-site scripting vulnerability in Drupal Lightgallery, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48447 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/lightgallery (Packagist): affected all versions; fixed in 1.6.0\n- drupal/lightgallery (Packagist): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48447/ (Markdown: https://insights.sbomify.com/CVE-2025-48447/index.md)","id":"CVE-2025-48447","markdown":"https://insights.sbomify.com/CVE-2025-48447/index.md","name":"CVE-2025-48447","record":{"aliases":["DRUPAL-CONTRIB-2025-069","GHSA-w5px-5878-m9x4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Lightgallery module","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Drupal Lightgallery module, potentially leading to session hijacking or data theft.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"lightgallery","vendor":"lightgallery_project"}],"cvss":{"score":7.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Lightgallery allows Cross-Site Scripting (XSS).This issue affects Lightgallery: from 0.0.0 before 1.6.0.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lightgallery - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-069","id":"CVE-2025-48447","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Admin Audit Trail - Less critical - Denial of Service - SA-CONTRIB-2025-068","id":"CVE-2025-48448"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"drupal/lightgallery","purl":null,"source":"GHSA-w5px-5878-m9x4"},{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"drupal/lightgallery","purl":"pkg:composer/drupal/lightgallery","source":"GHSA-w5px-5878-m9x4"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"drupal/lightgallery","purl":"pkg:composer/drupal/lightgallery?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-069"}],"prev":{"headline":"Commerce Alphabank Redirect - Moderately critical - Access bypass - SA-CONTRIB-2025-067","id":"CVE-2025-48446"},"products":["Lightgallery"],"published":"2025-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-11","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Drupal Lightgallery module, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2025-48447/"}