# CVE-2025-48447: Lightgallery - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-069

> An attacker can inject malicious scripts into web pages viewed by other users via the Drupal Lightgallery module, potentially leading to session hijacking or data theft.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2025
- **Updated:** 11 Jun 2025
- **Also known as:** DRUPAL-CONTRIB-2025-069, GHSA-w5px-5878-m9x4

## What is CVE-2025-48447?

CVE-2025-48447 is a high-severity cross-site scripting vulnerability in Drupal Lightgallery, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Lightgallery allows Cross-Site Scripting (XSS).This issue affects Lightgallery: from 0.0.0 before 1.6.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-48447?

2 open source packages ship an affected version, including drupal/lightgallery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/lightgallery` | Packagist | All versions | 1.6.0 |
| `drupal/lightgallery` | Packagist | All versions | 1.6.0 |
| `drupal/lightgallery` | Packagist:https://packages.drupal.org/8 | All versions | 1.6.0 |

Products: Lightgallery Project Lightgallery.

## How do I fix CVE-2025-48447?

Upgrade drupal/lightgallery to 1.6.0 or later.

## Is CVE-2025-48447 being exploited?

There is no known exploitation of CVE-2025-48447 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48447 and fix it if it is affected.

What it is: CVE-2025-48447 is a high-severity cross-site scripting vulnerability in Drupal Lightgallery, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48447 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/lightgallery (Packagist): affected all versions; fixed in 1.6.0
- drupal/lightgallery (Packagist): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48447/ (Markdown: https://insights.sbomify.com/CVE-2025-48447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48447
- OSV: https://osv.dev/vulnerability/CVE-2025-48447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48447/
Summaries are generated and may contain mistakes; the official description above is the record.
