# CVE-2025-48448: Admin Audit Trail - Less critical - Denial of Service - SA-CONTRIB-2025-068

> Attackers can cause denial of service in Drupal sites using the Admin Audit Trail module by triggering excessive resource allocation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jun 2025
- **Updated:** 11 Jun 2025
- **Also known as:** DRUPAL-CONTRIB-2025-068, GHSA-pwj7-5c7c-mwjc

## What is CVE-2025-48448?

CVE-2025-48448 is a medium-severity denial of service vulnerability in Drupal Admin Audit Trail, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in Drupal Admin Audit Trail allows Excessive Allocation.This issue affects Admin Audit Trail: from 0.0.0 before 1.0.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-48448?

2 open source packages ship an affected version, including drupal/admin_audit_trail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/admin_audit_trail` | Packagist | All versions | 1.0.5 |
| `drupal/admin_audit_trail` | Packagist | All versions | 1.0.5 |
| `drupal/admin_audit_trail` | Packagist:https://packages.drupal.org/8 | All versions | 1.0.5 |

Products: Admin Audit Trail Project Admin Audit Trail.

## How do I fix CVE-2025-48448?

Upgrade drupal/admin_audit_trail to 1.0.5 or later.

## Is CVE-2025-48448 being exploited?

There is no known exploitation of CVE-2025-48448 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48448 and fix it if it is affected.

What it is: CVE-2025-48448 is a medium-severity denial of service vulnerability in Drupal Admin Audit Trail, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48448 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/admin_audit_trail (Packagist): affected all versions; fixed in 1.0.5
- drupal/admin_audit_trail (Packagist): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48448/ (Markdown: https://insights.sbomify.com/CVE-2025-48448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48448
- OSV: https://osv.dev/vulnerability/CVE-2025-48448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48448/
Summaries are generated and may contain mistakes; the official description above is the record.
