{"answers":{"affected":"2 open source packages ship an affected version, including lomkit/laravel-rest-api.","exploited":"There is no known exploitation of CVE-2025-48490 in the wild and no public exploit code.","fix":"Upgrade lomkit/laravel-rest-api to 2.13.0 or later.","what":"CVE-2025-48490 is a medium-severity missing authorization vulnerability in Lomkit laravel-rest-api, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48490 and fix it if it is affected.\n\nWhat it is: CVE-2025-48490 is a medium-severity missing authorization vulnerability in Lomkit laravel-rest-api, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48490 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lomkit/laravel-rest-api (Packagist): affected all versions; fixed in 2.13.0\n- lomkit/laravel-rest-api (Packagist): affected all versions; fixed in 2.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48490/ (Markdown: https://insights.sbomify.com/CVE-2025-48490/index.md)","id":"CVE-2025-48490","markdown":"https://insights.sbomify.com/CVE-2025-48490/index.md","name":"CVE-2025-48490","record":{"aliases":["GHSA-69rh-hccr-cxrj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel API generator","requires_auth":"none","summary":"Attackers can bypass validation rules in Laravel Rest Api to inject unexpected parameters, leading to unauthorized data acceptance or processing.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-1173","name":"Improper Use of Validation Framework"}],"description":"Laravel Rest Api is an API generator. Prior to version 2.13.0, a validation bypass vulnerability was discovered where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. This issue has been patched in version 2.13.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Laravel Rest Api has a Search Validation Bypass","id":"CVE-2025-48490","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Project AI API Key Exposure in Source Code","id":"CVE-2025-48491"},"packages":[{"ecosystem":"Packagist","fixed":["2.13.0"],"introduced":["0"],"last_affected":[],"package":"lomkit/laravel-rest-api","purl":null,"source":"GHSA-69rh-hccr-cxrj"},{"ecosystem":"Packagist","fixed":["2.13.0"],"introduced":["0"],"last_affected":[],"package":"lomkit/laravel-rest-api","purl":"pkg:composer/lomkit/laravel-rest-api","source":"GHSA-69rh-hccr-cxrj"}],"prev":{"headline":"FreeScout Vulnerable to Stored XSS","id":"CVE-2025-48489"},"products":["laravel-rest-api"],"published":"2025-05-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["Lomkit"]},"summary":"Attackers can bypass validation rules in Laravel Rest Api to inject unexpected parameters, leading to unauthorized data acceptance or processing.","url":"https://insights.sbomify.com/CVE-2025-48490/"}