# CVE-2025-48490: Laravel Rest Api has a Search Validation Bypass

> Attackers can bypass validation rules in Laravel Rest Api to inject unexpected parameters, leading to unauthorized data acceptance or processing.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-69rh-hccr-cxrj

## What is CVE-2025-48490?

CVE-2025-48490 is a medium-severity missing authorization vulnerability in Lomkit laravel-rest-api, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laravel Rest Api is an API generator. Prior to version 2.13.0, a validation bypass vulnerability was discovered where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. This issue has been patched in version 2.13.0.

Weakness: CWE-20 (Improper Input Validation), CWE-1173 (Improper Use of Validation Framework)

## Which versions are affected by CVE-2025-48490?

2 open source packages ship an affected version, including lomkit/laravel-rest-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lomkit/laravel-rest-api` | Packagist | All versions | 2.13.0 |
| `lomkit/laravel-rest-api` | Packagist | All versions | 2.13.0 |

## How do I fix CVE-2025-48490?

Upgrade lomkit/laravel-rest-api to 2.13.0 or later.

## Is CVE-2025-48490 being exploited?

There is no known exploitation of CVE-2025-48490 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48490 and fix it if it is affected.

What it is: CVE-2025-48490 is a medium-severity missing authorization vulnerability in Lomkit laravel-rest-api, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48490 in the wild and no public exploit code.

Affected packages and fixed versions:
- lomkit/laravel-rest-api (Packagist): affected all versions; fixed in 2.13.0
- lomkit/laravel-rest-api (Packagist): affected all versions; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48490/ (Markdown: https://insights.sbomify.com/CVE-2025-48490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48490
- OSV: https://osv.dev/vulnerability/CVE-2025-48490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48490/
Summaries are generated and may contain mistakes; the official description above is the record.
