# CVE-2025-48493: Yii 2 Redis may expose AUTH paramters in logs in case of connection failure

> An attacker with log access can read Redis credentials exposed in plain text during connection failures in the Yii 2 Redis extension.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-g3p6-82vc-43jh

## What is CVE-2025-48493?

CVE-2025-48493 is a medium-severity vulnerability in yiisoft yii2-redis, published on 5 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Yii 2 Redis extension provides the redis key-value store support for the Yii framework 2.0. On failing connection, the extension writes commands sequence to logs. Prior to version 2.0.20, AUTH parameters are written in plain text exposing username and password. That might be an issue if attacker has access to logs. Version 2.0.20 fixes the issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-48493?

2 open source packages ship an affected version, including yiisoft/yii2-redis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2-redis` | Packagist | All versions | 2.0.20 |
| `yiisoft/yii2-redis` | Packagist | All versions | 2.0.20 |

Products: Yiiframework Yii2-Redis.

## How do I fix CVE-2025-48493?

Upgrade yiisoft/yii2-redis to 2.0.20 or later.

## Is CVE-2025-48493 being exploited?

There is no known exploitation of CVE-2025-48493 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48493 and fix it if it is affected.

What it is: CVE-2025-48493 is a medium-severity vulnerability in yiisoft yii2-redis, published on 5 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48493 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2-redis (Packagist): affected all versions; fixed in 2.0.20
- yiisoft/yii2-redis (Packagist): affected all versions; fixed in 2.0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48493/ (Markdown: https://insights.sbomify.com/CVE-2025-48493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48493
- OSV: https://osv.dev/vulnerability/CVE-2025-48493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48493/
Summaries are generated and may contain mistakes; the official description above is the record.
