# CVE-2025-48710: kro Confused Deputy vulnerability

> Attackers with resource creation permissions can deploy malicious container images, leading to remote code execution on cluster nodes.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-7633-x85h-5mqh, GO-2025-3741

## What is CVE-2025-48710?

CVE-2025-48710 is a medium-severity code injection vulnerability in kro.run kro, published on 4 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

kro (Kube Resource Orchestrator) 0.1.0 before 0.2.1 allows users (with permission to create or modify ResourceGraphDefinition resources) to supply arbitrary container images. This can lead to a confused-deputy scenario where kro's controllers deploy and run attacker-controlled images, resulting in unauthenticated remote code execution on cluster nodes.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2025-48710?

3 open source packages ship an affected version, including github.com/kro-run/kro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kro-run/kro` | Go | All versions | 0.2.1 |
| `github.com/kro-run/kro` | Go | From 0.1.0 | 0.2.1 |
| `github.com/kro-run/kro` | Go | From 0.1.0 | 0.2.1 |

## How do I fix CVE-2025-48710?

Upgrade github.com/kro-run/kro to 0.2.1 or later.

## Is CVE-2025-48710 being exploited?

There is no known exploitation of CVE-2025-48710 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48710 and fix it if it is affected.

What it is: CVE-2025-48710 is a medium-severity code injection vulnerability in kro.run kro, published on 4 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48710 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kro-run/kro (Go): affected all versions; fixed in 0.2.1
- github.com/kro-run/kro (Go): affected from 0.1.0; fixed in 0.2.1
- github.com/kro-run/kro (Go): affected from 0.1.0; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48710/ (Markdown: https://insights.sbomify.com/CVE-2025-48710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48710
- OSV: https://osv.dev/vulnerability/CVE-2025-48710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48710/
Summaries are generated and may contain mistakes; the official description above is the record.
